$re = '/^(\s*)/m';
$str = '<!DOCTYPE html>
<html>
<head></head>
<body>
<h1>My Site</h1>
<div id="block1">
<p>Hello, friend!</p>
<p>Read it:</p>
<ul>
<li>Item 1</li>
<li>Item 2</li>
<li>Item 3</li>
</ul>
</div>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);