const regex = /^(\s*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\s*)', 'gm')
const str = `<!DOCTYPE html>
<html>
<head></head>
<body>
<h1>My Site</h1>
<div id="block1">
<p>Hello, friend!</p>
<p>Read it:</p>
<ul>
<li>Item 1</li>
<li>Item 2</li>
<li>Item 3</li>
</ul>
</div>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}