import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s*)";
final String string = "<!DOCTYPE html>\n"
+ "<html>\n"
+ " <head></head>\n"
+ " <body>\n"
+ " <h1>My Site</h1>\n"
+ " <div id=\"block1\">\n"
+ " <p>Hello, friend!</p>\n"
+ " <p>Read it:</p>\n"
+ " <ul>\n"
+ " <li>Item 1</li>\n"
+ " <li>Item 2</li>\n"
+ " <li>Item 3</li>\n"
+ " </ul>\n"
+ " </div>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}