import re
regex = re.compile(r"^(\s*)", flags=re.MULTILINE)
test_str = ("<!DOCTYPE html>\n"
"<html>\n"
" <head></head>\n"
" <body>\n"
" <h1>My Site</h1>\n"
" <div id=\"block1\">\n"
" <p>Hello, friend!</p>\n"
" <p>Read it:</p>\n"
" <ul>\n"
" <li>Item 1</li>\n"
" <li>Item 2</li>\n"
" <li>Item 3</li>\n"
" </ul>\n"
" </div>\n"
" </body>\n"
"</html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")