re = /^(\s*)/m
str = '<!DOCTYPE html>
<html>
<head></head>
<body>
<h1>My Site</h1>
<div id="block1">
<p>Hello, friend!</p>
<p>Read it:</p>
<ul>
<li>Item 1</li>
<li>Item 2</li>
<li>Item 3</li>
</ul>
</div>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end