#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?://(www\.|m\.)?(reddit\.com|preview\.redd\.it|i\.redd\.it|redd\.it)/(((?!([\"'<])).)*)"
Local $sString = "https://reddit.com/r/lorem" & @CRLF & _
"https://preview.redd.it/r/ipsum" & @CRLF & _
"https://i.redd.it/r/dolor" & @CRLF & _
"https://redd.it/r/sit" & @CRLF & _
"https://www.reddit.com/r/lorem↵" & @CRLF & _
"https://www.preview.redd.it/r/ipsum↵" & @CRLF & _
"https://www.i.redd.it/r/dolor↵" & @CRLF & _
"https://www.redd.it/r/sit" & @CRLF & _
"https://m.reddit.com/r/lorem↵" & @CRLF & _
"https://m.preview.redd.it/r/ipsum↵" & @CRLF & _
"https://m.i.redd.it/r/dolor↵" & @CRLF & _
"https://m.redd.it/r/sit" & @CRLF & _
"https://no-reddit.com/r/lorem" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")