import re
regex = re.compile(r"https?://(www\.|m\.)?(reddit\.com|preview\.redd\.it|i\.redd\.it|redd\.it)/(((?!([\"'<])).)*)")
test_str = ("https://reddit.com/r/lorem\n"
"https://preview.redd.it/r/ipsum\n"
"https://i.redd.it/r/dolor\n"
"https://redd.it/r/sit\n"
"https://www.reddit.com/r/lorem↵\n"
"https://www.preview.redd.it/r/ipsum↵\n"
"https://www.i.redd.it/r/dolor↵\n"
"https://www.redd.it/r/sit\n"
"https://m.reddit.com/r/lorem↵\n"
"https://m.preview.redd.it/r/ipsum↵\n"
"https://m.i.redd.it/r/dolor↵\n"
"https://m.redd.it/r/sit\n"
"https://no-reddit.com/r/lorem\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")