use strict;
my $str = 'https://reddit.com/r/lorem
https://preview.redd.it/r/ipsum
https://i.redd.it/r/dolor
https://redd.it/r/sit
https://www.reddit.com/r/lorem↵
https://www.preview.redd.it/r/ipsum↵
https://www.i.redd.it/r/dolor↵
https://www.redd.it/r/sit
https://m.reddit.com/r/lorem↵
https://m.preview.redd.it/r/ipsum↵
https://m.i.redd.it/r/dolor↵
https://m.redd.it/r/sit
https://no-reddit.com/r/lorem
';
my $regex = qr/https?://(www\.|m\.)?(reddit\.com|preview\.redd\.it|i\.redd\.it|redd\.it)/(((?!([\"'<])).)*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}