re = /https?:\/\/(www\.|m\.)?(reddit\.com|preview\.redd\.it|i\.redd\.it|redd\.it)\/(((?!([\"'<])).)*)/
str = 'https://reddit.com/r/lorem
https://preview.redd.it/r/ipsum
https://i.redd.it/r/dolor
https://redd.it/r/sit
https://www.reddit.com/r/lorem↵
https://www.preview.redd.it/r/ipsum↵
https://www.i.redd.it/r/dolor↵
https://www.redd.it/r/sit
https://m.reddit.com/r/lorem↵
https://m.preview.redd.it/r/ipsum↵
https://m.i.redd.it/r/dolor↵
https://m.redd.it/r/sit
https://no-reddit.com/r/lorem
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end