# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img\s
(?=(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*?\salt=['"]([^"]*)['"]?)
(?:[^>=]|='[^']*'|="[^"]*"|=[^'"\s]*)*"\s?\\/?>/$1chat\/$2/gmix;t' <<< "<a href=\"gallery.com/gallery-name\"; target=\"_blank\"> <img class=\"aligncenter\" src=\"myblog.com/wp-content/image.jpg\" alt=\" I want to get this text\" width =\" 400 \" height=\"300\" /></a>
<img onmouseover=' alt=\"This is not the droid you are looking for\" ;' class=\"aligncenter\" src=\"myblog.com/wp-content/image.jpg\" alt=\"This is the droid I'm looking for.\" width =\" 400 \" height=\"300\" />"