use strict;
my $str = '<a href="gallery.com/gallery-name"; target="_blank"> <img class="aligncenter" src="myblog.com/wp-content/image.jpg" alt=" I want to get this text" width =" 400 " height="300" /></a>
<img onmouseover=\' alt="This is not the droid you are looking for" ;\' class="aligncenter" src="myblog.com/wp-content/image.jpg" alt="This is the droid I\'m looking for." width =" 400 " height="300" />';
my $regex = qr/<img\s
(?=(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*?\salt=['"]([^"]*)['"]?)
(?:[^>=]|='[^']*'|="[^"]*"|=[^'"\s]*)*"\s?\/?>/mixp;
my $subst = '$1chat/$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";