using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\s
(?=(?:[^>=]|='[^']*'|=""[^""]*""|=[^'""][^\s>]*)*?\salt=['""]([^""]*)['""]?)
(?:[^>=]|='[^']*'|=""[^""]*""|=[^'""\s]*)*""\s?\/?>";
string substitution = @"$1chat/$2";
string input = @"<a href=""gallery.com/gallery-name""; target=""_blank""> <img class=""aligncenter"" src=""myblog.com/wp-content/image.jpg"" alt="" I want to get this text"" width ="" 400 "" height=""300"" /></a>
<img onmouseover=' alt=""This is not the droid you are looking for"" ;' class=""aligncenter"" src=""myblog.com/wp-content/image.jpg"" alt=""This is the droid I'm looking for."" width ="" 400 "" height=""300"" />";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}