$re = '/<img\s
(?=(?:[^>=]|=\'[^\']*\'|="[^"]*"|=[^\'"][^\s>]*)*?\salt=[\'"]([^"]*)[\'"]?)
(?:[^>=]|=\'[^\']*\'|="[^"]*"|=[^\'"\s]*)*"\s?\/?>/mix';
$str = '<a href="gallery.com/gallery-name"; target="_blank"> <img class="aligncenter" src="myblog.com/wp-content/image.jpg" alt=" I want to get this text" width =" 400 " height="300" /></a>
<img onmouseover=\' alt="This is not the droid you are looking for" ;\' class="aligncenter" src="myblog.com/wp-content/image.jpg" alt="This is the droid I\'m looking for." width =" 400 " height="300" />';
$subst = "$1chat/$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;