const regex = /<img\s
(?=(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*?\salt=['"]([^"]*)['"]?)
(?:[^>=]|='[^']*'|="[^"]*"|=[^'"\s]*)*"\s?\/?>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img\\s
(?=(?:[^>=]|=\'[^\']*\'|="[^"]*"|=[^\'"][^\\s>]*)*?\\salt=[\'"]([^"]*)[\'"]?)
(?:[^>=]|=\'[^\']*\'|="[^"]*"|=[^\'"\\s]*)*"\\s?\\\/?>', 'gmi')
const str = `<a href="gallery.com/gallery-name"; target="_blank"> <img class="aligncenter" src="myblog.com/wp-content/image.jpg" alt=" I want to get this text" width =" 400 " height="300" /></a>
<img onmouseover=' alt="This is not the droid you are looking for" ;' class="aligncenter" src="myblog.com/wp-content/image.jpg" alt="This is the droid I'm looking for." width =" 400 " height="300" />`;
const subst = `$1chat/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);