// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mix)<img\s
(?=(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*?\salt=['"]([^"]*)['"]?)
(?:[^>=]|='[^']*'|="[^"]*"|=[^'"\s]*)*"\s?\/?>"#).unwrap();
let string = "<a href=\"gallery.com/gallery-name\"; target=\"_blank\"> <img class=\"aligncenter\" src=\"myblog.com/wp-content/image.jpg\" alt=\" I want to get this text\" width =\" 400 \" height=\"300\" /></a>
<img onmouseover=' alt=\"This is not the droid you are looking for\" ;' class=\"aligncenter\" src=\"myblog.com/wp-content/image.jpg\" alt=\"This is the droid I'm looking for.\" width =\" 400 \" height=\"300\" />";
let substitution = "$1chat/$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}