using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"location\s(?P<name>(?:\w+\s)?(?P<type>\w+))\slvl\.";
string input = @"You found hidden location Collapsed Mine lvl.70
То remember the route you associated it with simple combination: htoxpo
You found hidden location Fort lvl.69
То remember the route you associated it with simple combination: 4qunto
You found hidden location Tower lvl.67
То remember the route you associated it with simple combination: qGEV3o
You found hidden location Trusted Ruins lvl.66
То remember the route you associated it with simple combination: It0MMg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}