$re = '/location\s(?P<name>(?:\w+\s)?(?P<type>\w+))\slvl\./m';
$str = 'You found hidden location Collapsed Mine lvl.70
То remember the route you associated it with simple combination: htoxpo
You found hidden location Fort lvl.69
То remember the route you associated it with simple combination: 4qunto
You found hidden location Tower lvl.67
То remember the route you associated it with simple combination: qGEV3o
You found hidden location Trusted Ruins lvl.66
То remember the route you associated it with simple combination: It0MMg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);