package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)location\s(?P<name>(?:\w+\s)?(?P<type>\w+))\slvl\.`)
var str = `You found hidden location Collapsed Mine lvl.70
То remember the route you associated it with simple combination: htoxpo
You found hidden location Fort lvl.69
То remember the route you associated it with simple combination: 4qunto
You found hidden location Tower lvl.67
То remember the route you associated it with simple combination: qGEV3o
You found hidden location Trusted Ruins lvl.66
То remember the route you associated it with simple combination: It0MMg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}