use strict;
my $str = 'You found hidden location Collapsed Mine lvl.70
То remember the route you associated it with simple combination: htoxpo
You found hidden location Fort lvl.69
То remember the route you associated it with simple combination: 4qunto
You found hidden location Tower lvl.67
То remember the route you associated it with simple combination: qGEV3o
You found hidden location Trusted Ruins lvl.66
То remember the route you associated it with simple combination: It0MMg';
my $regex = qr/location\s(?P<name>(?:\w+\s)?(?P<type>\w+))\slvl\./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}