# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"location\s(?P<name>(?:\w+\s)?(?P<type>\w+))\slvl\."
test_str = ("You found hidden location Collapsed Mine lvl.70\n"
"То remember the route you associated it with simple combination: htoxpo\n"
"You found hidden location Fort lvl.69\n"
"То remember the route you associated it with simple combination: 4qunto\n"
"You found hidden location Tower lvl.67\n"
"То remember the route you associated it with simple combination: qGEV3o\n"
"You found hidden location Trusted Ruins lvl.66\n"
"То remember the route you associated it with simple combination: It0MMg")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.