// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)location\s(?P<name>(?:\w+\s)?(?P<type>\w+))\slvl\.").unwrap();
let string = "You found hidden location Collapsed Mine lvl.70
То remember the route you associated it with simple combination: htoxpo
You found hidden location Fort lvl.69
То remember the route you associated it with simple combination: 4qunto
You found hidden location Tower lvl.67
То remember the route you associated it with simple combination: qGEV3o
You found hidden location Trusted Ruins lvl.66
То remember the route you associated it with simple combination: It0MMg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}