using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/europa\/(.*)|\/afrika\/(.*)|\/asien\/(.*)|\/nordamerika\/(.*)|\/suedamerika\/(.*)|\/australien\/(.*)";
string input = @"https://reisememo.ch/europa/spanien
https://reisememo.ch/afrika/botswana
https://reisememo.ch/afrika/tansania
https://reisememo.ch/suedamerika/chile
https://reisememo.ch/europa/schweiz
https://reisememo.ch/europa/belgien
https://reisememo.ch/nordamerika/mexiko
https://reisememo.ch/asien/thailand
https://reisememo.ch/australien/queensland
https://reisememo.ch/persoenliche-hoteltipps
https://reisememo.ch/reisethema/restaurant
https://reisememo.ch/reisethema/wandern
https://reisememo.ch/review
https://reisememo.ch
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}