$re = '/\/europa\/(.*)|\/afrika\/(.*)|\/asien\/(.*)|\/nordamerika\/(.*)|\/suedamerika\/(.*)|\/australien\/(.*)/';
$str = 'https://reisememo.ch/europa/spanien
https://reisememo.ch/afrika/botswana
https://reisememo.ch/afrika/tansania
https://reisememo.ch/suedamerika/chile
https://reisememo.ch/europa/schweiz
https://reisememo.ch/europa/belgien
https://reisememo.ch/nordamerika/mexiko
https://reisememo.ch/asien/thailand
https://reisememo.ch/australien/queensland
https://reisememo.ch/persoenliche-hoteltipps
https://reisememo.ch/reisethema/restaurant
https://reisememo.ch/reisethema/wandern
https://reisememo.ch/review
https://reisememo.ch
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);