import re
regex = re.compile(r"\/europa\/(.*)|\/afrika\/(.*)|\/asien\/(.*)|\/nordamerika\/(.*)|\/suedamerika\/(.*)|\/australien\/(.*)")
test_str = ("https://reisememo.ch/europa/spanien\n"
"https://reisememo.ch/afrika/botswana\n"
"https://reisememo.ch/afrika/tansania\n"
"https://reisememo.ch/suedamerika/chile\n"
"https://reisememo.ch/europa/schweiz\n"
"https://reisememo.ch/europa/belgien\n"
"https://reisememo.ch/nordamerika/mexiko\n"
"https://reisememo.ch/asien/thailand\n"
"https://reisememo.ch/australien/queensland\n"
"https://reisememo.ch/persoenliche-hoteltipps\n"
"https://reisememo.ch/reisethema/restaurant\n"
"https://reisememo.ch/reisethema/wandern\n"
"https://reisememo.ch/review\n"
"https://reisememo.ch\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")