const regex = /\/europa\/(.*)|\/afrika\/(.*)|\/asien\/(.*)|\/nordamerika\/(.*)|\/suedamerika\/(.*)|\/australien\/(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/europa\\\/(.*)|\\\/afrika\\\/(.*)|\\\/asien\\\/(.*)|\\\/nordamerika\\\/(.*)|\\\/suedamerika\\\/(.*)|\\\/australien\\\/(.*)', 'g')
const str = `https://reisememo.ch/europa/spanien
https://reisememo.ch/afrika/botswana
https://reisememo.ch/afrika/tansania
https://reisememo.ch/suedamerika/chile
https://reisememo.ch/europa/schweiz
https://reisememo.ch/europa/belgien
https://reisememo.ch/nordamerika/mexiko
https://reisememo.ch/asien/thailand
https://reisememo.ch/australien/queensland
https://reisememo.ch/persoenliche-hoteltipps
https://reisememo.ch/reisethema/restaurant
https://reisememo.ch/reisethema/wandern
https://reisememo.ch/review
https://reisememo.ch
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}