// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/europa\/(.*)|\/afrika\/(.*)|\/asien\/(.*)|\/nordamerika\/(.*)|\/suedamerika\/(.*)|\/australien\/(.*)").unwrap();
let string = "https://reisememo.ch/europa/spanien
https://reisememo.ch/afrika/botswana
https://reisememo.ch/afrika/tansania
https://reisememo.ch/suedamerika/chile
https://reisememo.ch/europa/schweiz
https://reisememo.ch/europa/belgien
https://reisememo.ch/nordamerika/mexiko
https://reisememo.ch/asien/thailand
https://reisememo.ch/australien/queensland
https://reisememo.ch/persoenliche-hoteltipps
https://reisememo.ch/reisethema/restaurant
https://reisememo.ch/reisethema/wandern
https://reisememo.ch/review
https://reisememo.ch
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}