import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/europa\\/(.*)|\\/afrika\\/(.*)|\\/asien\\/(.*)|\\/nordamerika\\/(.*)|\\/suedamerika\\/(.*)|\\/australien\\/(.*)";
final String string = "https://reisememo.ch/europa/spanien\n"
+ "https://reisememo.ch/afrika/botswana\n"
+ "https://reisememo.ch/afrika/tansania\n"
+ "https://reisememo.ch/suedamerika/chile\n"
+ "https://reisememo.ch/europa/schweiz\n"
+ "https://reisememo.ch/europa/belgien\n"
+ "https://reisememo.ch/nordamerika/mexiko\n"
+ "https://reisememo.ch/asien/thailand\n"
+ "https://reisememo.ch/australien/queensland\n"
+ "https://reisememo.ch/persoenliche-hoteltipps\n"
+ "https://reisememo.ch/reisethema/restaurant\n"
+ "https://reisememo.ch/reisethema/wandern\n"
+ "https://reisememo.ch/review\n"
+ "https://reisememo.ch\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}