#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xs)(.+?)" & @CRLF & _
"\[{3}BREAK\]{3}"
Local $sString = "bleh blee BLOO" & @CRLF & _
"GOO ruu bum LUM Tum" & @CRLF & _
"sss ddf GHH rty" & @CRLF & _
"" & @CRLF & _
"[[[BREAK]]]" & @CRLF & _
"" & @CRLF & _
"gumpty RUMPTY BOBBY " & @CRLF & _
"JOE low blow" & @CRLF & _
"" & @CRLF & _
"[[[BREAK]]]" & @CRLF & _
"" & @CRLF & _
"BEEP boop bob" & @CRLF & _
"yellow green tam nim" & @CRLF & _
"reese yob" & @CRLF & _
"" & @CRLF & _
"[[[BREAK]]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")