import Foundation
let pattern = #"""
(.+?)
\[{3}BREAK\]{3}
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
bleh blee BLOO
GOO ruu bum LUM Tum
sss ddf GHH rty
[[[BREAK]]]
gumpty RUMPTY BOBBY
JOE low blow
[[[BREAK]]]
BEEP boop bob
yellow green tam nim
reese yob
[[[BREAK]]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)