// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xs)(.+?)
\[{3}BREAK\]{3}").unwrap();
let string = "bleh blee BLOO
GOO ruu bum LUM Tum
sss ddf GHH rty
[[[BREAK]]]
gumpty RUMPTY BOBBY
JOE low blow
[[[BREAK]]]
BEEP boop bob
yellow green tam nim
reese yob
[[[BREAK]]]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}