# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(.+?)
\[{3}BREAK\]{3}
"""
test_str = ("bleh blee BLOO\n"
"GOO ruu bum LUM Tum\n"
"sss ddf GHH rty\n\n"
"[[[BREAK]]]\n\n"
"gumpty RUMPTY BOBBY \n"
"JOE low blow\n\n"
"[[[BREAK]]]\n\n"
"BEEP boop bob\n"
"yellow green tam nim\n"
"reese yob\n\n"
"[[[BREAK]]]")
matches = re.finditer(regex, test_str, re.VERBOSE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.