using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)
\[{3}BREAK\]{3}";
string input = @"bleh blee BLOO
GOO ruu bum LUM Tum
sss ddf GHH rty
[[[BREAK]]]
gumpty RUMPTY BOBBY
JOE low blow
[[[BREAK]]]
BEEP boop bob
yellow green tam nim
reese yob
[[[BREAK]]]";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}