import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+?)\n"
+ "\\[{3}BREAK\\]{3}";
final String string = "bleh blee BLOO\n"
+ "GOO ruu bum LUM Tum\n"
+ "sss ddf GHH rty\n\n"
+ "[[[BREAK]]]\n\n"
+ "gumpty RUMPTY BOBBY \n"
+ "JOE low blow\n\n"
+ "[[[BREAK]]]\n\n"
+ "BEEP boop bob\n"
+ "yellow green tam nim\n"
+ "reese yob\n\n"
+ "[[[BREAK]]]";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}