import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-zA-Z0-9]+-){3,}[a-zA-Z0-9]+$";
final String string = "AA3A-123-NNN-D\n"
+ "12-OOO-12455-AS\n"
+ "AA3A-123-NNN-Dasdfasfd-23423423_234234\n"
+ "12-OOO-12455-AS123124-124123\n"
+ "123142-123123-3afdsafs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}