import Foundation
let pattern = #"^(?:[a-zA-Z0-9]+-){3,}[a-zA-Z0-9]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AA3A-123-NNN-D
12-OOO-12455-AS
AA3A-123-NNN-Dasdfasfd-23423423_234234
12-OOO-12455-AS123124-124123
123142-123123-3afdsafs
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)