# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-bA-B])\.([a-bA-B])/\1. \2/g;t' <<< "a.b
a.B
A.b
A.B"