$re = '/([a-bA-B])\.([a-bA-B])/';
$str = 'a.b
a.B
A.b
A.B';
$subst = "\1. \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;