// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-bA-B])\.([a-bA-B])").unwrap();
let string = "a.b
a.B
A.b
A.B";
let substitution = "\\1. \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}