import re
regex = re.compile(r"([a-bA-B])\.([a-bA-B])")
test_str = ("a.b\n"
"a.B\n"
"A.b\n"
"A.B")
subst = "\\1. \\2"
result = regex.sub(subst, test_str)
if result:
print(result)