using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-bA-B])\.([a-bA-B])";
string substitution = @"\1. \2";
string input = @"a.b
a.B
A.b
A.B";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}