re = /([a-bA-B])\.([a-bA-B])/
str = 'a.b
a.B
A.b
A.B'
subst = '\\1. \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result