# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\([^()]*\)//g;t' <<< "stuff (inside (nested) brackets) (and (some(are)) here) here
stuff (inside brackets) (and (some) here) here
stuff (and here) here"