const regex = new RegExp('\\([^()]*\\)', 'g')
const str = `stuff (inside (nested) brackets) (and (some(are)) here) here
stuff (inside brackets) (and (some) here) here
stuff (and here) here`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);