import Foundation
let pattern = #"\([^()]*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
stuff (inside (nested) brackets) (and (some(are)) here) here
stuff (inside brackets) (and (some) here) here
stuff (and here) here
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)