import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([^()]*\\)";
final String string = "stuff (inside (nested) brackets) (and (some(are)) here) here\n"
+ "stuff (inside brackets) (and (some) here) here\n"
+ "stuff (and here) here";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}