$re = '/\([^()]*\)/';
$str = 'stuff (inside (nested) brackets) (and (some(are)) here) here
stuff (inside brackets) (and (some) here) here
stuff (and here) here';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;