package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\([^()]*\)`)
var str = `stuff (inside (nested) brackets) (and (some(are)) here) here
stuff (inside brackets) (and (some) here) here
stuff (and here) here`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}