# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/\\/[a-z]+\.(?:[a-z]+\:?[0-9]+?|[a-z0-9]+\.[a-z]+)\\/\bassets\b\\/\bread\b\\/((\w)+\.png)/$1/g;t' <<< "//api.localhost:8000/assets/read/1453746564131_56a669843a3c1dac74170930.png
//api.olguat2.ca/assets/read/1453746564131_56a669843a3c1dac74170938.png
//api.authoring.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png
//api.whatever.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png
//api.whatever:8000/assets/read/1453746564131_56a669843a3c1dac741709333.png
"