const regex = /\/\/[a-z]+\.(?:[a-z]+\:?[0-9]+?|[a-z0-9]+\.[a-z]+)\/\bassets\b\/\bread\b\/((\w)+\.png)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\\/[a-z]+\\.(?:[a-z]+\\:?[0-9]+?|[a-z0-9]+\\.[a-z]+)\\\/\\bassets\\b\\\/\\bread\\b\\\/((\\w)+\\.png)', 'g')
const str = `//api.localhost:8000/assets/read/1453746564131_56a669843a3c1dac74170930.png
//api.olguat2.ca/assets/read/1453746564131_56a669843a3c1dac74170938.png
//api.authoring.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png
//api.whatever.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png
//api.whatever:8000/assets/read/1453746564131_56a669843a3c1dac741709333.png
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);