// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/\/[a-z]+\.(?:[a-z]+\:?[0-9]+?|[a-z0-9]+\.[a-z]+)\/\bassets\b\/\bread\b\/((\w)+\.png)").unwrap();
let string = "//api.localhost:8000/assets/read/1453746564131_56a669843a3c1dac74170930.png
//api.olguat2.ca/assets/read/1453746564131_56a669843a3c1dac74170938.png
//api.authoring.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png
//api.whatever.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png
//api.whatever:8000/assets/read/1453746564131_56a669843a3c1dac741709333.png
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}